I used to make single letter variables in QB45, to save memory. I had a few hundred variable names in some larger apps, and I honestly could remember what each one represented. Towards the end of the QB era, I made a cheat (hash) sheet, as it was getting a little hard to instantly recall those same variable letters. When QB64 came along, I slowly started naming variables, first as single words, and then a few years back, I started using compound words to make understanding the function easier. Now, I find myself wanting to do something like this...
a$ = "replace_decimal_point"
replace_decimal_point$ = a$
replace.decimal.point$ = a$
GOSUB replace_decimal_point
END
replace_decimal_point:
PRINT a$
PRINT replace_decimal_point$
PRINT replace.decimal.point$
RETURN
instead of...
a$ = "replacedecimalpoint"
replacedecimalpoint$ = a$
replacedecimalpoint$ = a$
GOSUB replacedecimalpoint
END
replacedecimalpoint:
PRINT a$
PRINT replacedecimalpoint$
PRINT replacedecimalpoint$
RETURN
Easier to site read with underscores or dots, right? Well, since I've never used this type of naming, I was not surprised the underscores were accepted, but I thought dots would have been reserved for TYPE defined variables. I'll probably go with he underscores, just to avoid that confusion when sharing code.
Comments welcomed, unless it's about my age... then $%^&_OFF.
Pete